text.skipToContent text.skipToNavigation
Home Support Projectors BrightLink Series Epson BrightLink 595Wi

There is no sound. What should I do?

    If there is no sound when you expect it or the volume is too low or high, try the following solutions:
    • Adjust the projector's volume settings.
    • Press the A/V Mute button on the remote control to resume video and audio if they were temporarily stopped.
    • Press the Source Search button to switch to the correct input source, if necessary.
    • Check your computer or video source to make sure the volume is turned up and the audio output is set for the correct source.
    • Check the audio cable connections between the projector and your video source.
    • If you do not hear sound from an HDMI source, set the connected device to PCM output.
    • Make sure any connected audio cables are labeled "No Resistance".
    • If you are using the USB Display function, turn on the Output audio from the projector setting in the Epson USB Display Settings program on your computer.
    • If you are using a Mac and you do not hear sound from an HDMI source, make sure your Mac supports audio through the HDMI port. If not, you need to connect an audio cable.
    • If you want to use a connected audio source when the projector is off, set the Standby Mode option to Communication On and the A/V Output option to Always On.
    • Make sure the Audio Output option is set to the correct audio port for your video device.
    • If you turn the projector on immediately after turning it off, the cooling fans may run at high speed momentarily and cause an unexpected noise. This is normal.
Published:  May 9, 2014 Was this helpful​? Thank you for the feedback!
Please tell us why this was not helpful.​
Please enter a valid email address