text.skipToContent text.skipToNavigation
Home Support Wearables Moverio Epson Moverio BT-300

Which drones are compatible with the drone edition of the product?

    See the list below:

    Note: To use a drone with the product, use the app DJI GO 3.1. The app is preloaded on the product.

    • DJI Inspire 1
    • DJI Inspire 2
    • DJI Matrice 600
    • DJI Mavic Pro
    • DJI Phantom 3 (Advanced and Professional series)
    • DJI Phantom 4
    • DJI Spark

    Note: Epson has not tested or certified compatibility with other manufacturer's drones.

    The Ultimate Flight app is compatible with the listed drones and is available at the Moverio Apps Market.
Published:  15-Dec-2016 Was this helpful​? Thank you for the feedback!
Please tell us why this was not helpful.​
Please enter a valid email address