text.skipToContent text.skipToNavigation
Home Support Projectors PowerLite Series Epson PowerLite Pro Cinema LS9600e

The product does not display images from the WirelessHD Transmitter. What should I do?

    If a WirelessHD source does not display correctly, try the following solutions:
    • Make sure WirelessHD is selected as the image source on the projector.
    • Open the WirelessHD reception monitor in the Settings menu and check the strength of the WirelessHD signal. If the signal is weak, you may need to move the transmitter closer to the projector or remove any large objects located between the transmitter and the projector.
    • Make sure that your projector is connected to the correct WirelessHD device. It can take up to 30 seconds for a signal to sync and appear after connecting.
    • You may need to reset the WirelessHD connection. Turn off both the WirelessHD transmitter and the projector. Start playback on your video device, then turn on the WirelessHD transmitter and the projector. Wait 10 seconds, then press the Setup button on the bottom of the transmitter.
    • Make sure the WirelessHD transmitter is within 32 feet (10 m) of the projector, isn’t obstructed by any large objects, and is not placed on a metal surface.
    • If the green and orange lights on the transmitter are flashing, the unit may be overheating. Make sure the vents on the back of the transmitter are not blocked and that the room temperature does not exceed 95 °F (35 °C).
    • If you are viewing wireless content, make sure that the WiHD light on the transmitter is on. If it is off, press the Output button on the remote control or transmitter.
Published:  Nov 7, 2014 Was this helpful​? Thank you for the feedback!
Please tell us why this was not helpful.​
Please enter a valid email address